Finshed tape, but loading problem...

Found a bug in R'n'D? Report it here!

Moderators: Zomis, Flumminator

Post Reply
User avatar
RAP
Posts: 285
Joined: Sat Jun 19, 2004 6:44 pm

Finshed tape, but loading problem...

Post by RAP » Sat Sep 09, 2006 12:35 am

Okay...

Just play the hardest level you can ever think of, and you think something in
the playfield is usually hard and you save the tape; after your done collecting
emeralds and went to the exit. You save it after that.

Well, whenever you think you wanted to load the finshed tape in front of your
friends or watch anyway... You'll see that your at the last save point instead
of finshing that level...

BTW: This bug also affects from the "buggy graphics editor" A.K.A. buggy Grab
Brush boxes... 8)

User avatar
bojster
Posts: 458
Joined: Fri Jun 18, 2004 7:42 pm
Location: Poland
Contact:

Post by bojster » Sat Sep 09, 2006 12:51 am

I'm not sure if it's the same, but I noticed a similar behaviour:
I play and I die. So I save the tape and then load it (not the snapshot, but by playing it and pausing before end) and then press record to append. But then if I want to do it again, i.e. save at some later position or finish a level and play the tape to watch, it will break at the moment I died for the first time. It seems that the recording is appended at the end of the tape regardless of it being paused at any given moment before that. A quick'n' dirty solution I came up with: I play the tape and pause when I want to start playing, but instead of pressing record, I press F1 and then F2 (to save tape and then load the snapshot). Then the tape seems to be ok. I'm not sure, maybe it's the correct behaviour, but it sure seems odd.

User avatar
RAP
Posts: 285
Joined: Sat Jun 19, 2004 6:44 pm

Post by RAP » Sat Sep 09, 2006 2:55 pm

bojster wrote:I play and I die.....
No, if you think you gonna die; just save the tape and don't die, when you go
to the exit and save automanicly (like pressing Enter and do it again...) and
then reload again incase you wanna watch... and you'll know what happened.

Maybe I'm send a video file of this... :?

User avatar
Holger
Site Admin
Posts: 2929
Joined: Fri Jun 18, 2004 4:13 pm
Location: Germany
Contact:

Post by Holger » Tue Oct 03, 2006 1:43 pm

> I play and I die. So I save the tape and then load it (not the snapshot, but
> by playing it and pausing before end) and then press record to append.
> But then if I want to do it again, i.e. save at some later position or finish a
> level and play the tape to watch, it will break at the moment I died for the
> first time.

This should definitely not happen. I've done some tests with the actual 3.2.2 and wasn't able to reproduce this, unfortunately. So some questions:

- Was this using version 3.2.2?
- Does it happen regularly for you, or only every now and then (for example, if you do some tests with a hard level or a level where it happened once)?

Unfortunately, this bug cannot be described by a test level and test tape, so I can only ask for some more details here... :-/

> maybe it's the correct behaviour, but it sure seems odd.

It definitely isn't correct behaviour, but clearly a bug. :-(

User avatar
bojster
Posts: 458
Joined: Fri Jun 18, 2004 7:42 pm
Location: Poland
Contact:

Post by bojster » Tue Oct 03, 2006 2:52 pm

It happened to me a few times when playing Contribution levels in 3.2.2. I don't remember having such problems earlier. I compiled the binary myself, but it shouldn't be a problem, as it didn't give any errors.

I might actually try to record a tape that is broken in this way and send it to you for some tests (because I don't think I have one of them still lying around).

User avatar
bojster
Posts: 458
Joined: Fri Jun 18, 2004 7:42 pm
Location: Poland
Contact:

Post by bojster » Tue Oct 03, 2006 5:10 pm

Hm, I can't seem to reproduce it either. Not that I tried very hard, but still. I'm pretty certain it happened in at least some contributed levels, but I don't remember which ones, and/or they were too long and I'm too lazy to try harder (and in short levels, as I have already said, I can't reproduce it). Too bad I replaced these broken tapes with the proper one, though I was even thinking about sending them to you... I will certainly do that if I encounter it again. And I might, as I'm now trying to complete (and sometimes fix) all the contributed levels (though I don't have much time, so it goes slowly – I'm only in 2002 now).

[edit] Now that I think of it, it might be related with unpredictable behaviour of some of the monsters – it sometimes happened that I finished a level (maybe even without recording/loading the tape in the meanwhile), but later when I watched/checked the tape – the yellow-capped fellow died in the middle of it! After a few cases like that I realised that the tape isn't really a 1:1 copy of the level solution, but utilises certain simplifications. Maybe here lies the problem?

Post Reply