sound card gets crazy

Found a bug in R'n'D? Report it here!

Moderators: Zomis, Flumminator

Post Reply
User avatar
Martijn
Posts: 794
Joined: Sat Jun 19, 2004 10:54 am
Location: the Netherlands (Holland)
Contact:

sound card gets crazy

Post by Martijn » Mon Aug 16, 2004 7:58 pm

This is not really a bug...

If there is in a level:
- background music
- a player who is digging sand
- 100 robots moving towards the player

...then the music malfunctions. Because of all those robots. Maybe it is possible to do one of these two things:
- improving the sound code of RnD
- changing the robot sound a little. Maybe it will help.

Not that this is a real bug, but it is something which has to be reported.
Visit my Boulder Dash website at:
http://www.bd-fans.com

Watch my avatar! That orange little thing is Murphy, the Supaplex star!

Yoshi348
Posts: 132
Joined: Fri Jun 18, 2004 8:27 pm
Location: My own little world (California)

Post by Yoshi348 » Mon Aug 16, 2004 8:04 pm

Oh, heh, I noticed that too, but I thought it was my computer's fault for being lame. Mostly, all those sounds just kind of break up eveything.

User avatar
Holger
Site Admin
Posts: 3231
Joined: Fri Jun 18, 2004 4:13 pm
Location: Germany
Contact:

Post by Holger » Tue Aug 17, 2004 8:49 am

Yes, I know. This seems to be a problem of the SDL_mixer library. Unfortunately, I cannot do much about it. I've tested the same scenario with the X11 version (which uses my own mixer code), and it sounds a lot better (although I get some "clicks" here and there).

Maybe this problem gets solved in a future version of SDL_mixer. Don't know if the developers of SDL_mixer know about that problem...

Post Reply