No sound coming from game at all

Discussion about Rocks'n'Diamonds, Boulder Dash, Supaplex, Emerald Mine and any other BD hybrid.

Moderators: Flumminator, Zomis

Post Reply
User avatar
Gavin
Posts: 71
Joined: Sun Dec 03, 2006 1:59 am
Location: Scotland

No sound coming from game at all

Post by Gavin »

(Win 7 Pro). No sound or music at all, I had sound for a little while when I downloaded it but now none at all.
User avatar
Gavin
Posts: 71
Joined: Sun Dec 03, 2006 1:59 am
Location: Scotland

Re: No sound coming from game at all

Post by Gavin »

An observation- it doesn't matter what version I'm using, but if I rename the .exe file the sound will start working again but only for a short while.
User avatar
Holger
Site Admin
Posts: 3453
Joined: Fri Jun 18, 2004 4:13 pm
Location: Germany
Contact:

Re: No sound coming from game at all

Post by Holger »

Hi Gavin,

this sounds very strange to me... Are you able to reproduce this issue on a different Windows 7 installation/machine, or is this problem specific to one single machine?
filbo
Posts: 492
Joined: Fri Jun 20, 2014 10:06 am

Re: No sound coming from game at all

Post by filbo »

Sounds like a mis-interaction with some sort of antivirus or other sort of system "protection" software.

And/or some sort of VIRUS itself.

Scan the system (can't say with what, haven't owned a Windows system in years).

Try disabling the various crutches, splints and wheelchairs (might be a good idea to turn off any sort of networking while doing such tests)...
User avatar
Gavin
Posts: 71
Joined: Sun Dec 03, 2006 1:59 am
Location: Scotland

Re: No sound coming from game at all

Post by Gavin »

It seems to be unique to my computer. There are no problems if I run R&D within a virtual machine.

At the moment the sound works as long as the filename is anything other than the original filename.

I am using Avast anti-virus, a recent scan found no viruses.
User avatar
Holger
Site Admin
Posts: 3453
Joined: Fri Jun 18, 2004 4:13 pm
Location: Germany
Contact:

Re: No sound coming from game at all

Post by Holger »

Very strange... Sounds like the filename of the binary triggers some specific behaviour regarding sound, but I have no idea at all what might have caused this... :-o
filbo
Posts: 492
Joined: Fri Jun 20, 2014 10:06 am

Re: No sound coming from game at all

Post by filbo »

Can you disable Avast for long enough to test that way?
Post Reply