Contributions 1995-98 bug!

Found a bug in R'n'D? Report it here!

Moderators: Zomis, Flumminator

Post Reply
Juusto
Posts: 15
Joined: Sat May 19, 2007 7:29 am
Location: Finland

Contributions 1995-98 bug!

Post by Juusto » Sat Oct 20, 2007 6:02 am

The rockford is moving too fast! When i play these levels in version 1.2.0 the rockford walks with normal speed. Do you know what is the problem?

User avatar
Sim_Piko
Posts: 18
Joined: Tue Sep 04, 2007 5:01 pm
Location: Poland

Post by Sim_Piko » Sat Oct 20, 2007 6:59 am

I hade this same thing when I tried to copy levels from "Original Boulder Dash"levelset. I found on the forum how to make the levels normal. If in the "levelinfo.conf" you add this line:

Code: Select all

latest_engine:                            true
levels work normal. Maybe this thing can help you? :roll:
Image

User avatar
Davacardo
Posts: 89
Joined: Sun Jul 22, 2007 10:36 am
Location: Australia

Post by Davacardo » Sat Oct 20, 2007 8:58 am

I noticed this too, but I always assumed it was due to the intial player speed being set to as if you have picked up a speed pill.
I checked just then; the player speed is set to Fast.

Juusto
Posts: 15
Joined: Sat May 19, 2007 7:29 am
Location: Finland

Post by Juusto » Sat Oct 20, 2007 1:34 pm

How do you add that line? When i click levelinfo.conf it just says: "Windows cant open this file"

User avatar
RTADash
Posts: 180
Joined: Sun May 27, 2007 11:33 am
Location: USA (Ohio)

Post by RTADash » Sat Oct 20, 2007 3:48 pm

You need to open it in notepad or wordpad - and then you'll be in configuration heaven. :)
Those who can't learn will teach; those who can't teach will learn.

Juusto
Posts: 15
Joined: Sat May 19, 2007 7:29 am
Location: Finland

Post by Juusto » Sun Oct 21, 2007 2:41 pm

Not working :( Could you explain little better? Which levelinfo do i really have to configurate?

Sorry about bad english

User avatar
RTADash
Posts: 180
Joined: Sun May 27, 2007 11:33 am
Location: USA (Ohio)

Post by RTADash » Sun Oct 21, 2007 6:46 pm

Find the folder that contains the levelset you're having trouble with, and locate the levelinfo.conf within that folder. Select it and windows will give you an option to select a program from the list. Do that and select notepad or wordpad. Once the file is opened, add "latest_engine: true" (without the quotes) somewhere within the text, and then save the file.
Hope this works out. :)
Those who can't learn will teach; those who can't teach will learn.

User avatar
Sim_Piko
Posts: 18
Joined: Tue Sep 04, 2007 5:01 pm
Location: Poland

Post by Sim_Piko » Sun Oct 21, 2007 8:47 pm

Zilberi wrote:Sorry about bad english
My english isn't good too
RTADash wrote:Hope this works out. :)
Look in INITIAL PLAYER SPEED in level editor before you add "latest_engine: true" in levelinfo.conf and after.
Before I had FAST speed and after - NORMAL.
Image

Juusto
Posts: 15
Joined: Sat May 19, 2007 7:29 am
Location: Finland

Post by Juusto » Tue Oct 23, 2007 1:21 pm

Still not working :( Am i doing something wrong? it reads now in Ben braitwates levelinfo:

latest_engine: truefile_identifier: ROCKSNDIAMONDS_LEVELINFO_FILE_VERSION_1.2

name: Ben Braithwaite

levels: 100

EDIT:They are all in one row really. I dont know why did they go that way when i copyed levelinfo text.

User avatar
RTADash
Posts: 180
Joined: Sun May 27, 2007 11:33 am
Location: USA (Ohio)

Post by RTADash » Tue Oct 23, 2007 2:27 pm

Try putting it somewhere after the file identifier. If problems persist (but, I hope they don't), could you paste the whole contents of your levelinfo.conf into your post? Good luck this time. :)
Those who can't learn will teach; those who can't teach will learn.

User avatar
Sim_Piko
Posts: 18
Joined: Tue Sep 04, 2007 5:01 pm
Location: Poland

Post by Sim_Piko » Tue Oct 23, 2007 5:59 pm

RTADash wrote:could you paste the whole contents of your levelinfo.conf into your post?
Here:

Code: Select all

file_identifier:        ROCKSNDIAMONDS_LEVELINFO_FILE_VERSION_3.1 ; add this line
name:                   boulder dash sim
author:                 Peter Liepa
imported_from:          Original Boulderdash
levels:                 100
first_level:            0
sort_priority:          100
latest_engine:          true ; add this line
level_group:            false
readonly:               false
handicap:               false
graphics_set:           bds_gfx
sounds_set:             bds_sfx
music_set:              bds_mus
Try to add "latest_engine" line and change "file_identifier" line into this one.
Image

Juusto
Posts: 15
Joined: Sat May 19, 2007 7:29 am
Location: Finland

Post by Juusto » Wed Oct 24, 2007 7:47 am

It worked! IT WORKED! I putted the text AFTER file indetifer and now it works! Thanks to you all :D

RTADash wrote:could you paste the whole contents of your levelinfo.conf into your post?


I pasted everything in my levelinfo.conf. what do you mean? :o

User avatar
RTADash
Posts: 180
Joined: Sun May 27, 2007 11:33 am
Location: USA (Ohio)

Post by RTADash » Wed Oct 24, 2007 1:42 pm

I wrote:If problems persist (but, I hope they don't), could you paste the whole contents of your levelinfo.conf into your post?
Just so I could check if anything was wrong. But as long as everything's working now, thats great! :D
Those who can't learn will teach; those who can't teach will learn.

Post Reply