Shortening file descriptions on RNDFA

Found a bug in R'n'D? Report it here!

Moderators: Zomis, Flumminator

Post Reply
Tomi
Posts: 339
Joined: Wed Aug 03, 2005 3:37 pm
Location: Slovakia

Shortening file descriptions on RNDFA

Post by Tomi » Tue Oct 24, 2006 4:13 pm

When I upload a file on RNDFA and then change it (through Manage Files), the description gets shortened.

Zomis
Posts: 1501
Joined: Mon Jun 21, 2004 1:27 pm
Location: Sweden
Contact:

Post by Zomis » Tue Oct 24, 2006 4:40 pm

I guess this is about this file? http://www.zomis.net/rnd/info.php?f=581

Could you tell me what the "real" description for it should be? Then I could investigate what's wrong.

Daniel H.
Posts: 535
Joined: Sun Apr 02, 2006 7:13 pm
Location: USA

Re: Shortening file descriptions on RNDFA

Post by Daniel H. » Tue Oct 24, 2006 11:10 pm

I used to have this problem, but eventually it mysteriously stopped. :shock:

I don't think that I did anything special, but I do not know for sure. :?

Tomi
Posts: 339
Joined: Wed Aug 03, 2005 3:37 pm
Location: Slovakia

Post by Tomi » Wed Oct 25, 2006 6:56 am

No, it's not about that file, because I manually corrected it (I was already aware of the bug at the time). The bug works like this: In the upload form, you upload the file and enter its correct description. Then you go to "Manage Files" -> "Change file" (e.g. to add categories to the file), but the description in the "Change file" form is shorter than real file description. When you submit the form, description gets overwritten by the shorter version. (I couldn't find any examples of this. Maybe it's already fixed?)

Zomis
Posts: 1501
Joined: Mon Jun 21, 2004 1:27 pm
Location: Sweden
Contact:

Post by Zomis » Wed Oct 25, 2006 8:33 am

Maybe it was caused earlier by some special chars in the description like ' and ". That was an issue I fixed a long time ago.

Haven't been changing anything about that during the last month though..

Zomis
Posts: 1501
Joined: Mon Jun 21, 2004 1:27 pm
Location: Sweden
Contact:

Post by Zomis » Sun Nov 12, 2006 12:09 pm

I have found out that the problem with the "-characters still exists. I'll try to investigate this more. Until later, try to avoid those characters.

Post Reply