Page 2 of 3

Posted: Tue Dec 13, 2005 10:05 am
by DiPal
Update at
In PPC version one action should mean one button press (I think).

Bug ?

Posted: Tue Dec 13, 2005 6:09 pm
by CharlyV
It seems last version have bug.
If i start RoNDi.exe i get RoNDi debug info:
" zip item not found "

The previous version doesn´t have this kind of message/bug.

Tested on iPAQ 5450 WM2003.



Posted: Wed Dec 14, 2005 7:41 am
by DiPal
Sorry, there was a bug.
Today version should work.

Posted: Wed Dec 14, 2005 11:10 am
by CharlyV
DiPal wrote:Sorry, there was a bug.
Today version should work.
Now it works well.
Congratulation for your nice port !

Posted: Fri Dec 16, 2005 1:43 am
by Guest
i tried the new version of your port and the punching is now good thank you but now the sound slows the game down a whole lot when a monster is in the level.

Posted: Mon Dec 19, 2005 7:16 am
by DiPal
Try today update.
Check speed when sound is on.

Posted: Mon Jan 30, 2006 9:24 am
by Guest
Runs on Qtek 9100 (Windows Mobile 5), but only in vertical scree mode. When rotating the screen the game rotates properly, but doesn't re-scale to the horizontal screen mode.

Posted: Thu Feb 02, 2006 11:51 pm
by Steffest

MANY thanks for this, DiPal !!!
It runs great on my Ipaq 4150.

I used to play emerald mines on the pocket PC port of the UAE Amiga emulator, but this is much much much faster.

Posted: Fri Feb 03, 2006 6:44 am
by DiPal
Qtek 9100 user
I know about this issue. But now I have no free time till March'06.

Nice to read this :D

Get last build from 1st Febuary 2006 at which runs much smoother with slower CPU usage.


Posted: Fri Mar 31, 2006 5:55 pm
by gigo
I have PalmOne Zire 72s and i have the Date book button over Addres book, that means that i've organized the left and right controls vertically :(

Treo 600 problems

Posted: Wed Apr 12, 2006 2:40 am
by R
Hello DiPal,

Rondi is great. Ever since the Amiga I have looked for an Emerald Mines for every computer and device I ever owned, now it is on my Treo 600. Can you port it to microwave oven...? :)

I have two problems to report for the Treo 600...

First. the hard keys are locked out of their normal function, when a message from another application is displayed. This is a serious problem for the Treo because after pushing the "on" button, the phone displays a message that the user must press a special hard key to unlock the other keys and touchscreen. The hard key is blocked by Rondi, so the only way to unblock the phone is to reset it by unscrewing the stylus! The hard keys also cannot be used to work the Rondi menus, though this is not so serious because I can use the stylus.

Second, the hard keys are not reconfigurable in the game. The Treo has a 4-way keypad, which I use by instinct for left and right, and it is very hard to get used to doing something different! Many rockfords have died as a result... :(

Otherwise, great work!

Posted: Mon May 01, 2006 9:13 pm
by Daniel H.
I have been using RoNDi for a while. It's very fun! :D

I have a PalmOne Zire 21 and I have no Memo Pad or ToDo List buttons, so I cannot snap objects or drop dynamite. :(

One possible solution would be to make an option for the Date Book and Address Book buttons to be snap field and drop dynamite, respectively. Then I could control the player with the stylus.

Another idea would be to make an option so that when you tap the player, he drops dynamite, and when you tap a space next to the player, he snaps that space. That could be hard to work with though...

Posted: Thu Aug 31, 2006 2:40 pm
by SlashEMc2k
DiPal wrote:Qtek 9100 user
I know about this issue. But now I have no free time till March'06.

Nice to read this :D

Get last build from 1st Febuary 2006 at which runs much smoother with slower CPU usage.
Hehehe.. Now I have something to do at work. :D
I have a Windows Mobile 5 - Xda Exec
520mhz, 64mb Ram, 128mb flash lcd 480-640TFT

I have downloaded the latest version
but I keep getting the following errors popup on screen:
"Frame 126 has MDL_Other 743"
It happens every so often in game.

Also when the (screen/level) moves across the game slows down loads?

And I have the same problem as Qtek 9100 but I just turn the screen size the other way round and it works :)

But other than that this is great!
Thanks for the release it is great I can`t wait to see your next update ;)

Posted: Sun Sep 03, 2006 6:33 pm
by pfalcon

Great port! Where source code for it can be found?


To slow on VGA

Posted: Mon May 14, 2007 12:57 pm
by Xerner
I tried running Rocks'n'Diamonds on FSC N560 with VGA-display,
but scrolling is to slow so RnD is not really playable on VGA.

Any hint or patch available to allow playing on VGA ?