Page 1 of 1

Small graphical problem

Posted: Tue Aug 18, 2015 8:14 pm
by Coaxl
Okay, I haven't really been able to narrow it down to when exactly the problem appears, but I've just started playing RnD for the first time since I installed Windows 7 and since then I've been getting this problem. Occasionally, something just goes utterly wrong with the graphics, and it's hard to describe what happens without inserting a pic, so...


Yeah. What usually seems to happen is that (I think) a column, row, or some other formation of tiles have another kind of tile painted over them - in this case, walls (the sand is still visible below the wall tiles above). This does not change the level itself, but makes it very confusing to play. It seems to happen most often when I get killed by a monster, and then reload a saved position. The whole position is then screwed up no matter how many times I try to reload. Getting killed again and again just changes which column is screwed up. This is a very weird bug that completely kills the gaming experience. Anyone know why this could be?

Re: Small graphical problem

Posted: Mon Aug 24, 2015 1:32 pm
by Holger
This very much looks the same as a bug already reported some time (years) ago; unfortunately I cannot find the corresponding bug report at the moment, and I also cannot find the commit message when I fixed it (at least I think that I fixed it). Therefore, I'm currently not sure if this problem should already have been fixed in your version ( (and therefore would in fact not be fixed after all), or if it is only fixed in the current development version (

At least this similar bug also mixed up a single row or column of the tile graphics, to it seems to be more or less the same one.

If there is any chance to reproduce this problem, please let me know!

Until then, I'll continue trying to find the forum post that reported that similar bug with similar screenshots (and also what I wrote to it), and I'll also try to find the potential bugfix in the commit messages (to see what caused it).

Re: Small graphical problem

Posted: Mon Aug 24, 2015 6:11 pm
by Anonycat
I reported it here, where I mentioned it was still erratic on I haven't been keeping up with Git much.

Re: Small graphical problem

Posted: Tue Aug 25, 2015 9:50 pm
by Holger
Thanks a lot, Coaxl, for bringing this topic up again, and thanks a lot, Anonycat, for pointing me to you original bug report of this misbehaviour.

Fortunately, I was now able to track it down to the Git commit where I fixed that bug -- the corresponding commit message is a little bit misleading, and I'm quite sure that I did not have this specific bug in my mind when fixing it (and writing the commit message, which in fact was a ChangeLog entry at that time), because apparently I was thinking about it as being a different (although very similar) bug (affecting only small tile graphics).

Just for the records, it's the following commit which fixed that bug:

Code: Select all

commit 9ea8b203a29569f4d2ed059d33def627ff2b17aa
Author: Holger Schemel <>
Date:   Wed May 14 01:56:16 2014 +0200

    * fixed level redraw after quick-loading tape with small tile graphics
And indeed, I changed something in "RedrawPlayfield()" there, which seems to make sense.

To be sure, I've just did quite some tests with the Git checkout right before that commit, and then with the following one (the commit mentioned above), using "Snake Bite", level 30, and doing quite some "quick saving" and "quick loading" while walking through the first room of that (multi-room) level, which clearly shows that bug various times without the commit, while the graphical glitch never showed up anymore when applying the commit that apparently fixes it.

So it seems that this bug already reported by quite some people for over one year is fixed now in the development / Git version of R'n'D -- time to roll it out as an official new version of the game... :-)