[v4.0.0.2] TAS keys broken and potential key-input (timing?) problem(s)

Found a bug in R'n'D? Report it here!

Moderators: Flumminator, Zomis

Post Reply
tormen
Posts: 4
Joined: Mon Aug 07, 2017 2:39 pm

[v4.0.0.2] TAS keys broken and potential key-input (timing?) problem(s)

Post by tormen » Tue Aug 22, 2017 8:50 am

Hi,

I am currently stuck at this level: Emerald Mine - Level 007

1.) TAS keys (for me: ASDW (assigned like cursor-keys) seem broken, because:
When repeatedly pressing TAS keys, sometimes the character MOVES instead of SNAPPING.
From what I understood about TAS keys (to be SNAPPING keys) this should never happen.
Maybe I am mistaken ?

2.) But before trying to use TAS keys, I actually first tried:
Using the Left Alt (SNAP Field key) + cursor keys (Movement keys) to snap the diamonds and then release the Alt and move back.
But either I don't move back, but stay,
or it does not take the Alt into consideration and I move forward.
I never had any of such problems. I replayed the level over and over trying different timings, etc. SOMETIMES "it just works" but I got the strong impression that this might be a bug.

Looking around I found this potentially releated issue:
viewtopic.php?f=7&t=2311

1.) is at least clearly showable, happens right away afer a few repeated TAS key-strokes in the same direction.
2.) but this is a very fuzzy problem. Not sure how to better report on it :/

I could try to film me trying to solve the levels ? ... or doing a screencast, but then you don't see my "real" inputs ...
I also saw the various --execute CLI commands. Please let me know what you might need.

This isn't the most difficult level of them all and I would like to move on ;)
Please heeeeelp :))

Tormen

filbo
Posts: 211
Joined: Fri Jun 20, 2014 10:06 am

Re: [v4.0.0.2] TAS keys broken and potential key-input (timing?) problem(s)

Post by filbo » Wed Aug 23, 2017 10:20 pm

Your (1) is certainly one of the things I mentioned in that other post. Holger sounded like he was going to go poke at it, don't know if a solution is on it's way...

Your (2) seems like it might depend on your operating system, version, etc. Basically I am thinking that some OSes may react in certain ways to pressing or holding down 'Alt'; e.g. take it as 'open the operating system menu' or 'open the application menu' etc. -- and if the app is in a mode where that can't happen, it might still cause some effect which would eat an input key (or some such trouble).

To deal with that, you might try reconfiguring your RnD keyboard mappings to use Ctrl rather than Alt. That's usually of less interest to the OS...

I use Left-Ctrl for 'snap' and Right-Ctrl for 'light fuse'; feel like these are defaults from very long ago, but it's also possible that I changed them so long ago they only feel like defaults :)

User avatar
Holger
Site Admin
Posts: 2752
Joined: Fri Jun 18, 2004 4:13 pm
Location: Germany
Contact:

Re: [v4.0.0.2] TAS keys broken and potential key-input (timing?) problem(s)

Post by Holger » Mon Aug 28, 2017 9:53 am

1.) TAS keys (for me: ASDW (assigned like cursor-keys) seem broken, because:
When repeatedly pressing TAS keys, sometimes the character MOVES instead of SNAPPING.
From what I understood about TAS keys (to be SNAPPING keys) this should never happen.
That's right, this should never happen. I was able to reproduce this buggy behaviour, but wasn't able to find the bug that caused it (mainly due to lack of time analyzing it, not necessarily because it's that hard or complex to debug)...
Your (1) is certainly one of the things I mentioned in that other post.
Yes, it's this one:
There is another similar bug (might easily be a different manifestation of the same bug) in which the TAS keys cause the player to move. This is much easier to reproduce, in fact trivial: start any level, then hit 'jjjjjjjjj' a bunch of times. You'll move left some of the time. Hit 'jkjkjkjkjkjkkjkjkjk' (hammering both keys); you'll move left/right erratically. There is some pace at which you can hit 'j[pause]j[pause]j[pause]etc' and not move; this might be 200ms per 'j' or something like that. Faster than that, and you move.
(I must admit that I had nearly overseen this second bug below the first one (which is described in more length.)

As this bug can easily be reproduced, I expect it to be debugged and fixed soon.
2.) But before trying to use TAS keys, I actually first tried:
Using the Left Alt (SNAP Field key) + cursor keys (Movement keys) to snap the diamonds and then release the Alt and move back.
But either I don't move back, but stay,
Hmm, I think I don't understand this one. What do you mean by "move back" in this context?
or it does not take the Alt into consideration and I move forward.
Yes, this should be the same bug as (1). (This bug will happen with both TAS snap keys and "normal snapping" using <modifier key> plus <direction key>.)
I use Left-Ctrl for 'snap' and Right-Ctrl for 'light fuse'; feel like these are defaults from very long ago, but it's also possible that I changed them so long ago they only feel like defaults :)
No, these are indeed the default keys for "snap" and "drop".

tormen
Posts: 4
Joined: Mon Aug 07, 2017 2:39 pm

Re: [v4.0.0.2] TAS keys broken and potential key-input (timing?) problem(s)

Post by tormen » Fri Sep 15, 2017 5:58 pm

Hi,

Thanks a lot for your replys :)) ... I just had missed them and only now checked for progress and found them.

"move back" ... yeah it really is to be understood literally: meaning I try to move in the opposite direction than the direction of the snap.

But without further explanation this is really confusing!

Moving back is my attempt to compensate for the bug with the snap not working reliably and "not working" means it moves FORWARD instead of snapping, hence I am "snapping" and right after moving back to maybe survive even if the snap failed and I accidentally had moved forward.

Hope this explanation helps.

If I could run super debug output enabled app version giving you more insight on what is happening, I would be happy to!

Tormen

User avatar
Holger
Site Admin
Posts: 2752
Joined: Fri Jun 18, 2004 4:13 pm
Location: Germany
Contact:

Re: [v4.0.0.2] TAS keys broken and potential key-input (timing?) problem(s)

Post by Holger » Tue Sep 19, 2017 2:09 pm

I just had missed them and only now checked for progress and found them.
Hint: You can subscribe to any sub-forum to get mail notifications for all new posts! :-)
Moving back is my attempt to compensate for the bug with the snap not working reliably and "not working" means it moves FORWARD instead of snapping, hence I am "snapping" and right after moving back to maybe survive even if the snap failed and I accidentally had moved forward.
Makes sense now! Thanks for the explanation! :-D

BTW: This bug is already fixed now, and the corrected behaviour will be available with the next release version (or immediately from Git, for those who can build the game by themselves). :)

filbo
Posts: 211
Joined: Fri Jun 20, 2014 10:06 am

Re: [v4.0.0.2] TAS keys broken and potential key-input (timing?) problem(s)

Post by filbo » Tue Sep 19, 2017 7:06 pm

I noticed that fix go by : )

Built and have been using it for some amount of game play.

On the very first level I played with the change, I noticed one instance of unexpected movement when using TAS keys. But I have not been able to reproduce it since then, even with vigorous key-mashing. At the time of the 'error' I felt that I had possibly fumbled slightly on the keyboard, *might* have touched some other key -- not a fully clean 'reproduction'. So I am keeping a suspicious eye, but I guess I can say that so far 'it works', or at least 'it almost completely works'...

tormen
Posts: 4
Joined: Mon Aug 07, 2017 2:39 pm

Re: [v4.0.0.2] TAS keys broken and potential key-input (timing?) problem(s)

Post by tormen » Tue Sep 19, 2017 9:23 pm

@Holger: Thanks !!

Subscribe to topic: Yeah, Somehow I am used to be autosubscribed if you create a topic (e.g. file a bug) ;)
But I am subscribed now :)

"This bug is already fixed" : Sounds great :) ... So I am looking forward to version 4.0.0.3 :))

Just to clarify: "This bug" refers to both problems descibed here or only the one that I had clarified about ?

User avatar
Holger
Site Admin
Posts: 2752
Joined: Fri Jun 18, 2004 4:13 pm
Location: Germany
Contact:

Re: [v4.0.0.2] TAS keys broken and potential key-input (timing?) problem(s)

Post by Holger » Fri Sep 22, 2017 12:17 pm

"This bug is already fixed" : Sounds great :) ... So I am looking forward to version 4.0.0.3 :))
The new version will probably be 4.0.1.0 due to some other enhancements (mainly highly improved game controller support).
Just to clarify: "This bug" refers to both problems descibed here or only the one that I had clarified about ?
Oops, sorry, this was misleading -- it's the first bug you reported that is definitely fixed now.

The second bug you reported *should* also be fixed now (as there should be no scenario anymore where a "snap+<direction>" could go wrong, regardless of how fast it was typed). However, I'm a bit unsure about this, as you wrote that this bug never happened to you before, while the bug I've fixed was lurking in the code for many releases now. So it's probably best if you could just try by yourself as soon as a new release is available. (I would just create an intermediate development version for you (Windows version preferred?), but before I want to fix that horrendous bug that filbo reported in the other (related) thread (this one: http://www.artsoft.org/forum/viewtopic.php?f=7&t=2323).)

User avatar
Holger
Site Admin
Posts: 2752
Joined: Fri Jun 18, 2004 4:13 pm
Location: Germany
Contact:

Re: [v4.0.0.2] TAS keys broken and potential key-input (timing?) problem(s)

Post by Holger » Fri Sep 22, 2017 12:20 pm

So I am keeping a suspicious eye, but I guess I can say that so far 'it works', or at least 'it almost completely works'...
Please let me know immediately if you should ever encounter this again (with being sure that you really only touched the TAS snap keys). I'm quite sure that the bug should be finally fixed now, but one never really knows for sure... :-o :-)

tormen
Posts: 4
Joined: Mon Aug 07, 2017 2:39 pm

Re: [v4.0.0.2] TAS keys broken and potential key-input (timing?) problem(s)

Post by tormen » Fri Sep 22, 2017 2:34 pm

Sounds great.

I can't wait that the version with the fix gets officially released here: http://www.artsoft.org/rocksndiamonds/

@Holger: Thanks again !! - Top.

Post Reply