bug: -SDL1 completely blank display

Found a bug in R'n'D? Report it here!

Moderators: Flumminator, Zomis

Post Reply
filbo
Posts: 180
Joined: Fri Jun 20, 2014 10:06 am

bug: -SDL1 completely blank display

Post by filbo » Fri Apr 22, 2016 2:48 am

This is a new misbehavior, but not entirely new in the code. It seems that my ~/.rocksndiamonds/setup.conf (or possibly some other file) now has some setting in it which causes some of my -SDL1 binaries not to display.

That is, I start up any of 20160418-SDL1, 20160419-SDL1, or 20160421-SDL1, and the window is blank blackness. It's the expected size with the expected title; expected stderr appears, and the EMC startup music. If I hit ESC, downarrow a few times, <Enter><Enter> (thus selecting "Quit", "Y"), it exits -- so it's working just fine, except no display.

The next older binary (20160319-SDL1), as well as a random sampling of even older ones, work fine. All -SDL2 binaries work fine.

Eyeball examination of setup.conf does not show anything obvious. I assume -SDL1 binaries ignore properties pertaining only to -SDL2, e.g. "window_scaling_percent: 100"; certainly they never had trouble in the recent past.

Aha... Ran an old one that worked, changed some setting, saved, now new binary works. Diffing the old and new setup.conf, I added back:

> screen_rendering_mode: stream_texture_only

and -SDL1 again doesn't work.

User avatar
Holger
Site Admin
Posts: 2668
Joined: Fri Jun 18, 2004 4:13 pm
Location: Germany
Contact:

Re: bug: -SDL1 completely blank display

Post by Holger » Fri Apr 22, 2016 6:12 pm

That's funny, I experienced the same buggy behaviour by myself yesterday. ;-)

As you've already found out, it's caused by a rendering mode setting in the config file not supported by SDL1.

I've fixed this by always forcing the (only) supported (bitmap based) rendering mode in the SDL1 version, regardless of what the "setup.conf" file says. (Already available from Git.)

filbo
Posts: 180
Joined: Fri Jun 20, 2014 10:06 am

Re: bug: -SDL1 completely blank display

Post by filbo » Fri Apr 22, 2016 9:23 pm

I confirm: this is fixed. Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests