RnD Engine + Small Graphics + save/load tape bug

Found a bug in R'n'D? Report it here!

Moderators: Flumminator, Zomis

Post Reply
emeraldminer
Posts: 3
Joined: Wed Apr 16, 2014 11:20 pm

RnD Engine + Small Graphics + save/load tape bug

Post by emeraldminer » Mon Apr 28, 2014 12:19 am

hi!

today i used the save/load function and the level becomes unplayable. it only happens with the rnd engine combined with small graphics. supaplex,em engine works and rnd engine with normal graphics works.

level before i load tape: Image

level after i load: Image

User avatar
Holger
Site Admin
Posts: 2758
Joined: Fri Jun 18, 2004 4:13 pm
Location: Germany
Contact:

Re: RnD Engine + Small Graphics + save/load tape bug

Post by Holger » Mon Apr 28, 2014 7:13 pm

I was able to reproduce this -- wow, that's really a nasty bug! :-o

Apparently it only happens when the playfield is smaller than the visible area, and there should be no scrolling at all in such a case (but it does, and it is not soft scrolling, but jump scrolling).

I hope to be able to fix this soon...

User avatar
Holger
Site Admin
Posts: 2758
Joined: Fri Jun 18, 2004 4:13 pm
Location: Germany
Contact:

Re: RnD Engine + Small Graphics + save/load tape bug

Post by Holger » Tue Aug 25, 2015 10:06 pm

In fact, this is the same bug which also affects normal-sized graphics (in a similar scenario). Thanks for this bug report which helped a lot finding and fixing it.

This bug is fixed in the current Git version (by commit 9ea8b203a29569f4d2ed059d33def627ff2b17aa, already some time ago).

Hope the fix will be available in a release version soon.

Post Reply